AnsweredAssumed Answered

Issue with X-NUCLEO-IDW04A1

Question asked by Olivier Frenette on Apr 13, 2018
Latest reply on Apr 15, 2018 by Olivier Frenette

Hi,

 

I recently bought the following development boards : 

 

- NUCLEO-L476RG

- X-NUCLEO-IDW04A1 (Wifi expansion board)

 

I am also using the following software packages: 

 

- STM32Cube_FW_L4_V1.11.0

- STM32CubeExpansion_WIFI1_V3.1.1

- System workbench for STM32 (SW4STM32)

- I believe I have the latest ST-LINK driver : V2.J30.M20

 

The NUCLEO-L476RG works great. I have programmed it with a few different projects from the package and everything works fine. The problem I have is when I try using the WiFi expansion board. I have tried all the examples that come with the package (Client, Server, Http request, WiFi_VCOM). I have had no luck with all of these. The WiFi expansion board just doesn't seem to do anything. I get stuck during the Wifi initialize process (see figure 1).

 

I am assuming the Wifi expansion board is not flashed properly. So, I tried to flash it using the STM procedure :X-NUCLEO-IDW0xx1- FW upgrading over UART_v1.2. I already have a problem during the first step of this procedure. When I drag and drop the .bin file in the nucleo drive, I get a fail.txt file (figure 2), and the board keeps on turning ON and OFF until windows tell me there is a problem with the device (duh). 

 

Since I can't drag and drop the file, I tried to program the board using the tool : STM32 ST-LINK Utility (figure 3). Seems like this works fine, but I can't know for sure. At this point, I can't get anything out of a serial terminal. After that, I follow the instructions to program the expansion board using JMP2, and the flash loader tool. The procedure tells me to make sure that the start address is 0x8002800, but sector 5 for me is 0x8020000 (figure 3). The tool won't let me change it, so I don't wanna risk programming it and overwriting something important and bricking the whole thing.

 

I also tried the quick start guide for IDW04A1. The document says to drag and drop the .bin file of the WiFi-VCOM project in the nucleo drive. When I do this, I get the same behavior as mentionned before. I also tried to program it with both SW4STM32 and the ST-lINK utility, but all I get from the serial terminal is a bunch of crap (figure 4).

 

I believe I am doing exactly what STM documentations says, I have the jumpers placed where they need to be. I have absolutely no clue what to do next. 

 

Any help or shared similar experience is appreciated! I feel like the only thing that would solve this is just to buy another board. 

 

Thank you,

 

Olivier

Outcomes