AnsweredAssumed Answered

Can't get IG2 work on either INT1 or INT2 for Lis3de

Question asked by Kefei Yao on Apr 8, 2018
Latest reply on Apr 9, 2018 by Kefei Yao

I encountered a problem that IG2 doesn't get detected on either INT1 or INT2 pin. I confirm the IG1 work on both INT1 and INT2. Followings are the combinations I tried (CTRL REG1,2,4,5 kept unchanged):

The INTx_CFG,INTx_THS, INTx_Duration are set same for IG1 and IG2.

1) CTRL_REG1 - CTRL6

{

     0x57, 

     0x39,

     0x40, //IG1 route to INT1

     0x00,

     0x40, //Enable FIFO mode

     0, //Disable INT2 

}

In this configuration, IG1 is correctly detected on INT1 pin.

2) CTRL_REG1 - CTRL6

{

     0x57, 

     0x39,

     0x20, //IG2 route to INT1

     0x00,

     0x40, //Enable FIFO mode

     0, //Disable INT2 

}

In this configuration, IG2 is *NOT* correctly detected on INT1 pin

3) CTRL_REG1 - CTRL6

{

     0x57, 

     0x39,

     0, //Disable INT1

     0x00,

     0x40, //Enable FIFO mode

     0x40, //IG1 route to INT2

}

In this configuration, IG1 is correctly detected on INT2 pin

4) CTRL_REG1 - CTRL6

{

     0x57, 

     0x39,

     0, //Disable INT1

     0x00,

     0x40, //Enable FIFO mode

     0x20, //IG2 route to INT2

}

In this configuration, IG2 is *NOT* correctly detected on INT2 pin.

 

What am I missing?

Outcomes