AnsweredAssumed Answered

f_print vs F_write in FatFs

Question asked by greenwood.greg on Apr 6, 2018
Latest reply on Apr 9, 2018 by Clive One

I am working with F746G-Discovery board running the project application FatFs_uSD built in the repository.  The application runs using the code as is which writes the data to the uSD with the f_write function.  There is also a f_printf function in ff.c.  When I try to call it from main the compiler throws an error indicating the function is not defined.  This is odd since it is in the same ff.c file.  The function is declared in both the ff.h and ff.c and the function is not static.  I checked to see if possibly the directory where the ff.c and ff.h are contained are not in the includes directory list.  Sure enough the folder is not in the list.  So I added it but the same result occurs.  So why is the compiler giving the error?  And why is the f_write not coming up as undefined when the directory containing the files are not in the include list.  I even tried #include "ff.h" in the top of main and still the errors occurs with f_printf. 

Comments?

 

PS. ff.c and ff.h are in the Middlewares>FatFs>Core folder in the repository.

Outcomes