AnsweredAssumed Answered

F401RE VL53L1X debug issue

Question asked by albagir themut on Mar 21, 2018
Latest reply on Mar 23, 2018 by Clive One

Hello,

 


i'm quite new to the embedded world and purchased the VL53L1X evaluation kit with the F401RE and the
NUCLEO-53L1A1. I installed all the drivers and the System Workbench on my Windows 10 setup and got the example application running. Now to my problem:

 

After trying out different stuff my applications were always stuck in HAL_Delay(). On the first debug everything always worked, but when I restarted the applications to debug again it always went infinite in HAL_Delay(). The only thing that helped was to startup Vl53L1X GUI to reset the microcontroller paired with an hard reset by pushing the button on the microcontroller. But it just takes too much time to do that, so I tried reinstalling everything (STSW-009, STSW-Link007). But that didn't help. Stepping through the applications always seems to work, but as soon as I resume the application it gets stuck again.

 

I hope you guys can help me with my problem.

 

BR

albagir

Outcomes