AnsweredAssumed Answered

IIS2DH Interrupt 1 and Interrupt 2 signal generation

Question asked by Ranjith Ravindra Shanbhag on Mar 9, 2018
Latest reply on Mar 12, 2018 by Miroslav B

Hello,

 

I am trying to get both Interrupts 1 and 2 to trigger for two different movements and at different intervals of the time . But somehow only interrupt 2 is getting generated. Interrupt 1 is not getting called at all.

 

So, I wanted to check if interrupt 1 is getting generated from the IIS2DH in the first place. So, I removed the Interrupt 2 connection and had only interrupt 1. I used the same configuration that I used for Interrupt 2 generation for Interrupt 1 generation. Surprisingly, interrupt 1 was still not getting generated.

 

Below is my accelerometer configuration with Interrupt 2 only:

CTRL_REG1: 0x3F;

CTRL_REG4: 0x20;

INT2_CFG:     0x04;

INT2_THS:      0x05;

INT2_DUR:     0x01;

 

The above configuration worked perfectly with interrupt 2. When I used Interrupt 1 with the same configuration, it did not work. The configuration is as follows:

CTRL_REG1: 0x3F;

CTRL_REG4: 0x20;

INT1_CFG:     0x04;

INT1_THS:      0x05;

INT1_DUR:     0x01;

 

I don't understand why interrupt 1 doesn't generate for the same configuration for which interrupt 2 can work. Please help me.

 

Thanks

Outcomes