AnsweredAssumed Answered

SPWF04SA Certificate Error: 4 on TLS Port with FRED

Question asked by Mario Ghecea on Feb 28, 2018
Latest reply on Mar 14, 2018 by Mario Ghecea

I am having an issue with an IOT Provider known as FRED (sensetecnic.com) I have a sandbox up there but I can only access it via HTTPPOST and open sockets on port 80. On port 443 (TLS) I get an error with the certificate on the filesystem...

 

When I try to connect now from my code with the sensetecnic cert on sdcard, I get Error : 4

 

It’s always complaining about the cert even on a simple socket connection to 443. It only works on 80 apparently! 

 

 

>>Station started in STA mode...

 

 

 

>>inverterLockoutCounter = 6

 

 

 

>>Connecting to socket

 

 

 

>>Socket Open OK

 

 

 

>>Socket ID: 0

 

 

 

AT+S.SOCKON=54.149.86.44,443,NULL,s

 

 

 

 

AT-S.Certificate Error:4

 

 

 

 

AT-S.ERROR:74:Failed to open socket

 

 

 

 

>>Socket Response Time-out!

 

2A : 40 00 00 79 00 00 73 00 01 00 26 19 25 21 2D 00 00 00 02 58 00 FF 00 00 00 00 00 00 E8 57 00 20 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

 

 

Certificate error #4 corresponds to :

 

 

 

It appears that the common name has a wildcard in it…I wonder if that might be what is going on! Not sure how to get around this...I have attached the CA cert for *.sensetecnic

 

I also get bizarre error messages in the Google Chrome. On my home laptop I do not see these issues...

 

Outcomes