AnsweredAssumed Answered

ST-Link debugging problem / ST-Link Utility problem

Question asked by Eetu Piukkula on Feb 26, 2018
Latest reply on May 21, 2018 by Clive One

Hi,

 

I was doing my thing, writting and debugging code with System Workbench and after a while ST-Link refused to work anymore, out of the blue. I had not changed SWD pins nor related settings. It just stopped working. First I thought that I forgot to close previous debug session. But after restarts I was not able to make it work. After many Google searches I found that a lot of people are having trouble with ST-Link from start of the 2018. At that time I had updated everything from CubeMX to SWB and Linux resources. Error message changed from wrong ID to general Init() failure. Well, I also had Win10 system. It has not been updated (ST related) since last year. ST-Link Utility gave same error as in this video ST Link USB Communication Error (silverware) - YouTube . Even when no board is connected to ST-Link. You can see that I asked if person who made the video had solved the issue. He has not.

 

Basically when ST-Link is plugged, what ever is you first action it works, but second action, for example refreshing device made "USB Communication error". I probed serial lines with oscilloscope. When ST-Link is plugged there is traffic, but after that literally nothing will work, line stays pulled high thou. ST-Links light stays always solid red.

 

Is this a bug or something? Have been 2 days now banging my head to the wall.

 

--Eetu Piukkula

Outcomes