AnsweredAssumed Answered

ST-LINK Usb Communication error

Question asked by Logan MacKenzie on Feb 8, 2018
Latest reply on Feb 8, 2018 by Clive One

I have a custom board (based heavily on the Nucleo) using the STM32F767II that I am trying to flash. I have flashed this board in the past using the CN6 header on a Nucleo board and using the St-Link to flash my PCB instead of the Nucleo. The other day I was flashing my board and testing some minor modifications to my firmware and flashing the board was working fine, but on the third or fourth time I tried to flash the board, I got the error "USB communication error". I am using Atollic TrueStudio (on Windows 10) and was flashing the board from it, but I also tried using the ST-LINK Utility to connect to the board, but neither is working now. I have double-checked that my wiring between the Nucleo and the board is the same as it was when it was working fine and everything seems good. The changes I made to my firmware were minor, insignificant changes so I highly doubt that they have anything to do with this issue. Is there something in the debug settings or configurations in TrueStudio that I could have done that would prevent me from re-flashing the board afterwards? Does it matter whether I power up the board first or plug in the Nucleo? Is there a way to reset the board? Thanks!

Outcomes