AnsweredAssumed Answered

How to disable Censorship on SPC560C50L3

Question asked by SIBIN THOMAS on Feb 8, 2018
Latest reply on Feb 16, 2018 by SIBIN THOMAS

Hello Everyone,

   I am working on SPC560C50L3 controller and using UDE STK 4.8 software for loading the firmware. I wanted to enable censorship. After going through the community I was able to get a code to erase shadow flash an enable censorship from below link.

https://community.st.com/thread/44142-shadow-flash-erase

I took the SPC560BCxx_RLA Flash Test Application from SPC5 Studio which runs from RAM. I commented CFlash and DFlash testing part along with the Shadow flash locking from the above code. Then I copied the code for enabling the censorship from the above link and build it. Then using the JTAG and UDE STK 4.8 I loaded the code to my MCU step by step using the Debug option. After power on reset, my MCU is running my application code (not the example). But I am not able to update new firmware because JTAG is not connecting to target.

 

Message from component 'PpcJtagTargIntf' :
Can't connect target !
Message from component 'PpcJtagTargIntf' :
Failed to connect probably because of wrong processor state !
Please check:
- JTAG cable and Target Power
- Target's boot configuration
- Target's PLL configuration
- Censorship password configuration !
Message from component 'PpcJtagTargIntf' :
Processor is in UNKNOWN state !
Message from component 'PpcJtagTargIntf' :
Failed to halt processor !

 

 I have already tried the censorship unlock feature under xPC56x/xPC57 Options in UDE STK 4.8. I have also tried reversing the password. Password I used is the default password (0xFEEDFACE,0xCAFEBEEF). Did I enable the censorship correctly, or did I miss something. Any suggestion would be helpful.

Regards

SIBIN.

Outcomes