AnsweredAssumed Answered

Chip broken? Restoring Chip functionality with ST Link

Question asked by P K on Jan 31, 2018
Latest reply on Feb 22, 2018 by dhenry

Hello,

 

I have been working with an STM32F437 chip for a while now, when suddenly I could not flash my program in my IDE anymore. I tried solving the issue in ST Link Utility.

 

First of all, the only mode in which I can connect to the chip is HotPlug mode. I can't get any connection to the chip with normal or with connect under reset mode. I also tried pulling the reset-pin of the chip low/ releasing it when connecting. Also, in hotplug mode, my chip does not get recognized correctly.

 

Only Hot Plug mode works

Connect under reset

 

I tried erasing the chips content, (again also tried it when toggling the reset pin), but I always get the message "readout protection enabled". So I went to the option bytes menu and tried disabling it. However, this error occurs:

 

Disable ReadOut Protection

 

When I enter that menu while I actively pull down the reset pin, the page looks a bit different (e.g. distinct levels of readout protection). But I still am not able to disable the readout protection. In other menus, I often get the following error:

 

Can't halt the core

 

 

What else is there I could do? Is there any possibility of restoring the chips functionality? Or has it simply broken. The issue arised very suddenly when debugging some code, it worked fine before. It also does not seem to run the last program I flashed onto it (some LEDs should blink, but they don't).

 

Any help is greatly appreciated, also please excuse any language errors, I'm not a native speaker.

 

Best regards,

 

Pascal

Outcomes