AnsweredAssumed Answered

Trouble updating ST Workbench

Question asked by Lynn Linse on Jan 17, 2018
Latest reply on Jan 17, 2018 by Clive One

This isn't a question, but a suggestion. I've always had trouble running AC6 Eclipse "Updates", I'd usually get a "Connection Reset" error, over and over, until one day it would work. Previously, I'd assumed the host server was too busy.

 

But I discovered that my company is running one of those aggressive "hardware firewalls" which was blocking the download of JAR files - our site includes warehouse people, so even USB flash usable is restricted. The few times upgrade worked, I now see that I'd been running a personal VPN (I use NordVPN, but many are available.) I run the VPN, because when I travel I don't trust public or hotel WiFi - and at work, it allows me past the IT browsing rules, which include blocking hotmail & other "time-wasters".

 

I've now tested this assumption twice, and both times with the VPN active, the AC6/Workbench/Eclipse update works fast and flawlessly. So if you are having trouble updating Eclipse, get a free (or trial or paid) VPN and try again.

Outcomes