AnsweredAssumed Answered

Hard debugger and processor lockup when accessing QSPI on an STM32F746 MCU

Question asked by Michael Stauffer on Jan 11, 2018
Latest reply on Feb 13, 2018 by Michael Stauffer

Hello,

I'm using an STM32F746 MCU with a Lauterbach uTrace probe.   We are running into an issue where the processor and debugger are locking up hard when memory mapped reads from qspi flash addresses are occurring simultaneously with interrupts that read from other registers on the AHB busses.  When it gets into this state, the debugger is not able to halt the processor or give us any other clues as to what is going on. The only way to get out of the state seems to be a reset.  We have tried both SWD and JTAG, and tried both JLINK and Lauterbach probes with similar results.  I have also tried setting break points on the exception handlers, and it doesn't appear that we are getting any processor exceptions.  The issue occurs across different qspi flash vendors.

 

I have found that setting the qspi chip select timeout to 1 in the QUADSPI_LPTR seems to work around the issue.  Originally I had the timeout set to 128. I have found a few other values for the timeout that also seem to work around the issue.  Disabling the timeout also appears to fix the issue. Simply working around the issue concerns me though, because I don’t know what the root cause of the problem is.

 

Has anyone else ran into this type of issue, and do you have any suggestions on how to get to root cause?

 

Thanks,

Michael

Attachments

Outcomes