AnsweredAssumed Answered

SPBTLE-1S - How to get a BLE connection?

Question asked by Wolfgang Reinig on Jan 7, 2018
Latest reply on Feb 12, 2018 by Wolfgang Reinig

Hi,

 

I just got the EVAL-IDB007V1M with the spbtle-1s (based on bluenrg-1 and installed the STSW-BLUENRG1-DK (v2.5.0) on my Windows PC. The BlueNRG-1 Navigator recognizes the EVAL-IDB007V1M and I can 'Flash & Run' the basic examples and the BLE demonstration and test applications.

 

They seem to run on the EVAL-IDB007V1M - at least they to something when I press the buttons but I get strange results.

 

First, when I 'Flash & Run' the BlueNRG-1 Hello World from the basic examples I get this output:

Output of BlueNRG-1 Hello World

 

With another terminal program it looks like this:

 

I expected Hello World... What's wrong?

 

Second problem (and more severe in my case): When I flash and run the BLE demonstration and test applications I would expect to be able to establish a connection to the EVAL-IDB007V1M from my Android smartphone. I tried to use the Apps STM32 BLE Profiles, BlueNRG and (sorry for that) nRF Connect. But I couldn't get any connection to the  EVAL-IDB007V1M. I tried several demo applications, e.g. BLE Beacon.

 

The Apps and the BLE stuff on my smartphone works in general and I can connect to other BLE devices.

 

Again: What's wrong?

 

TIA

Wolfgang

Outcomes