AnsweredAssumed Answered

STM32F334R8 Internal Temperature and USART

Question asked by Georg Busch on Jan 2, 2018
Latest reply on Jan 10, 2018 by T J

Hi there,

Setup:

STM32F334R8 on a NUCLEO-F334R8 on a custom PCB with power supply, CAN tranceiver, I2C slaves and RS232 Tranceiver.

uVision5 Toolchain and STM32CubeMX

 

Problem: I want to read out the internal temperature of the MCU, but the reading of ADC1->DR is always 0x0FFF

 

Stuff I tried: Every piece of code from the internet ..., the project that comes with the Cube FW F3, reading out Vref and Vbat. But the value always stays the same.

 

Now the weird part: When I remove the Nucleo board from my PCB (more specifically PA3 - configured as USART_RX), select U5V on JB5 (power from USB not external), the value suddenly drops and keeps changing within the LSB. After converting the value to celsius, the temperature is legit. I started a new project with nothing but ADC1 (no USART), the behavior is still the same.

 

Question: Is it normal that internal measurements and USART on PA3 on a NUCLEO-F334R8 won't work together? According to the schematics nothing should interfere with Vref or Avdd (looking at you, SB61).

 

Any Tips?

Outcomes