AnsweredAssumed Answered

Possible bug in STM32F429ZIT6 Discovery1 board user manual?

Question asked by _LardDork _ on Dec 19, 2017
Latest reply on Dec 22, 2017 by Imen D

Hi folks,

 

I've been working on USB peripheral for like two weeks initially I picked up Discovery1 STM32F429x then later switched to Discovery STM32F407x and I'll explain why.

 

I tried running USB CDC Virtual Com Port on F429 using USB_FS which according to boards user manual is connected to the microUSB (CN6), code I generated using CubeMx and result was I couldn't see Com port when I did "dmesg" on the terminal.

Then few days after struggling I flashed USB CDC Virtual Com Port project for USB_HS and Com port showed up in the list but then again when I tried to send a string (pClassData in the descriptor was NULL so transmit function returned fail) it didn't work, but this is not something I'm trying to discuss here.

 

After this I further investigated about FS and schematic shows USB_FS is what being also used by ST-Link.

USB_FS Pins: PA11 and PA12

USB_HS Pins: PB14 and PB15

and attached are two snapshots from Board's user manual.

 

Additional info: If I follow the exact same steps for STM32F407x with USB_FS and STM32F429x with USB_HS and again try to send a string over USB, it works for F407x but not for the F429x. I also did the diff no core differences, so difference must have been when control goes to USB_ISR.

 

So my question is am I the only one who's faced this issue, and is it an actual bug or am I'm doing something silly somewhere?

 

Document name: UM1670

Pages: 29 and 30

 

 microUSB_connectorST-Link_using_USB_FS

Outcomes