AnsweredAssumed Answered

STM32F7 ethernet issues in RMII mode

Question asked by Mairo Leier on Dec 10, 2017
Latest reply on Dec 19, 2017 by Mairo Leier

I have a STM32F767 and STM32F746 nucleo dev kits. Both seems to be "Z" models.

 

I developed RTOS based TCP server based on netconn that receives and transmits data over ethernet. STM does not answer to the ping nor sending/receiving any data. On the ethernet plug both green and yello LEDs are on. Problem is that after several restarts ethernet starts working until the next restart, if I am lucky. I have noticed that eth works only when green LED is off on the ethernet plug.

 

At first I thought problem is on my SW side. I developed similar server using RAW sockets, then tried with UDP client - same issues.

At first I tried with STM32F767 but then replaced it with STM32F746 just for testing purposes - still same issues.

Reading errata sheets I saw similar problems but looks like that they should all be fixed with "Z" model.

 

From the dev board schematic (http://www.st.com/content/ccc/resource/technical/document/user_manual/group0/26/49/90/2e/33/0d/4a/da/DM00244518/files/DM… ) I have disconnected jumper SB177 not to reset ETH controller after STM restarts. If I reset manually my ETH controller from the same jumper so that green LED stays off then I can do whatever with my STM (reprogram,...) then ethernet remains functional.

 

To me it looks like the same issue as here STM32F777 revision A RMII errata symptoms which should be fixed now.

 

Currently, whatever I develop with my ethernet based nucleos I hit all the time with same issue. Any ideas?

Outcomes