AnsweredAssumed Answered

STLink USB driver trouble on AC6 Eclipse

Question asked by Yannick Marietti on Dec 2, 2017

Hello,

 

I am facing a bug in AC6 SystemWorkbench STM32 software and I request you help. Being a total newbie on STM32, it is also highly probable that the corrective action is an evident one for more experienced users ...

 

 

Here is the follows the full description of my issue.

 

I first generate an initialization code on CubeMX for a NUCLEO-L476RG card.

Then, I open this project with AC6/SystemWorkBench STM32, I add a few lines of codes to make integrated LED blinking and I start a debug session.

I immediately get the following error report from Eclipse IDE:

 

Unplugged target or STLink already in use or STLink USB driver not installed
Open On-Chip Debugger 0.10.0-dev-00005-g4030e1c-dirty (2017-10-25-10:55)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
srst_only separate srst_nogate srst_open_drain connect_assert_srst
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
padded zone erase set to 1
adapter_nsrst_delay: 100
adapter speed: 480 kHz
Info : tcl server disabled
Info : telnet server disabled
Info : clock speed 480 kHz
Error: open failed (no matching adapter found)
in procedure 'init'
in procedure 'ocd_bouncer'

 

Currently USB installed driver is this one :

 

STSW-LINK009 - ST-LINK, ST-LINK/V2, ST-LINK/V2-1 USB driver signed for Windows7, Windows8, Windows10 - STMicroelectronic… 

 

I tried this on several different computers, running Windows 7 and Windows 10 OSes. AC6 is failing exactly the same way.

 

I finally did the debug and run steps using ARM Keil µvision 5 instead aof AC6 Eclipse, using the above USB driver, the same Nucleo card, the same USB cable, and everything worked fine (debug session OK, LED blinking as expected - so my program is correct.).

 

Can you help me in any way ?

 

Best regards

 

Yannick

Outcomes