AnsweredAssumed Answered

STEVAL-MKI109V2 USB driver won't load

Question asked by Madhu Siddalingaiah on Nov 30, 2017
Latest reply on Dec 1, 2017 by Madhu Siddalingaiah

I have an STEVAL-MKI109V2 board for evaluating MEMS accelerometers.

I downloaded the Unico software for Windows (I'm running Windows 7) from the ST website and installed it.

I didn't realize the USB driver install was separate, so when I plugged in the device into my computer it wasn't recognized.

So I unplugged the eval board, installed version 1.04 (current version) of the USB driver.

The install was successful, but when I plug in the board, the driver does not load, device manager reports Code 28, which means the driver was not found.

I tried rebooting, uninstalling, reinstalling, nothing worked. I found the registry entry for the ST USB device and tried to delete it, but Windows would not allow me to do that. This has become really painful.

I went to another Windows computer and installed the driver and Unico app before plugging in the board and it worked perfectly the first time.

So now I have one computer that works with the eval board and one that doesn't, not a great result.

I scoured the forums, Google, and YouTube, but nothing I tried has fixed the problem on my Windows 7 machine.

Why doesn't Windows find the driver even though it is installed?

Outcomes