AnsweredAssumed Answered

STM32Cube F4 V1.17.0 has incorrect CMSIS GCC library

Question asked by kim.chris.001 on Nov 3, 2017
Latest reply on Nov 8, 2017 by Dana Myers

Hi ST,

 

I have just downloaded "STM32Cube_FW_F4_V1.17.0" and found it has "libarm_cortexM7l_math.a" in CMSIS folder.

There is no cortexM4 file so I am confused if M7 library is compatible with M4.

 

I think this is a mistake because I can't seem to find any info on your release note about this.

I can use V1.16.0 M4 library instead of V1.17.0 M4 but I would use the new one if M4 lib has been updated. 

 

Cheers.

Chris

Outcomes