AnsweredAssumed Answered

Anyone Ever Get The STM32F4 Virtual COM Port Working w/Windows 10?

Question asked by Terence D on Oct 27, 2017
Latest reply on Nov 2, 2017 by Clive One

I see multiple people having this problem but not seen an answer why or a solution: The Virtual COM Port driver (1.4) is not working for Windows 10 users.  I have the same problem.  I download the Driver from: STM32 Utilities - STMicroelectronics I run the installation process and also note in the contained readme.txt it says:

 

 

How to use
***************

1- Uninstall previous versions (Start-> Settings-> Control Panel-> Add or remove programs)

2- Run your "VCP_V1.4.0_Setup.exe"

3- Go to Your installation directory - Example, C:\Program Files (x86)\STMicroelectronics\Software\Virtual comport driver

4- Go to Your OS version directory ([Win7] or [Win8])
+ Then :
- Double click on dpinst_x86.exe if you are running a 32-bits OS version
- Double click on dpinst_amd64.exe if you are running a 64-bits OS version
+ Follow the instructions.

 

Since I have 64 bit Windows 10 I run dpinst_amd64.exe.  The installation appears to work, but no "ST Microelectronics" COM port shows up in my device manager, only COM1:

 

 

I am quite certain COM1 is in no way related to my STM32F411 board.  Anyone know how to get this to work?

Outcomes