AnsweredAssumed Answered

Is it dead? FAIL.TXT

Question asked by Derek Kwan on Oct 23, 2017
Latest reply on Oct 23, 2017 by Derek Kwan

Excited getting the STM32L476 Nucleo-64 board from the ST event last week. Was trying to program it past few days. Tried some examples from mbed with IDW01M1 WiFi module. But it was iffy, at times program just hangs, hitting reset it will work for a while...

 

Then this afternoon, all of the sudden, board failed to respond. And the USB drive shows up with a FAIL.TXT contain the following message "The interface firmware FAILED to reset/halt the target MCU"

 

OK, that explains what happens. Hitting reset button does nothing. Time to check with Google... Followed a few suggestions...

 

Tried STSW-LINK007 with "ST-LinkUpgrade.exe", update seems to work. (but just mean ST-Link is working, not the STM32L476)

 

Tried to flash again following the example from ST workshop using "CleanAzure_Sns_DM.bat", as expected, report No target connected (again because STM32L476 is dead?)

 

As someone suggest to use Windows STM32 ST-LINK utility", holding RESET button and do target -> erase chip, no go.

 

Question: Is it dead? If yes, too bad, my experience is short lived.

Outcomes