AnsweredAssumed Answered

Can't flash SPIRIT1 dongle STEVAL-IDS001V5M from DK

Question asked by kubicky.jay.001 on Oct 17, 2017
Latest reply on Oct 18, 2017 by kubicky.jay.001

I have an STEVAL-IDS001V5M dongle I'm trying to test.  I installed the SPIRIT1 DK v. 2.2.1 on my Windows 10 PC.  During the install one of the driver installations fails (the usbser device installed by dpinst_amd64.exe), but my dongle still comes up as a COM port.  Two other device drivers are installing correctly, and I've tried multiple re-installs of the first driver but it always fails.

 

Despite the failure I can connect to my dongle via Putty and talk to it ok.  When I run the SPIRIT1 DK GUI it finds the COM port for the dongle (COM27 in my case) and when I open it I get 'Old GUI Firmware detected.  Now a firmware update procedure will be started...'.  When I click OK I get a warning about making sure the orange LED is flashing and the COM port disappears from the device manager (I guess the board is being put into DFU mode).  The orange LED is flashing so I click Apply but then, after about 10 seconds, I get a 'No DFU board found' error (but the orange LED is still flashing).  I then need to unplug and re-plug the dongle to get the COM port back.

 

Any idea what's going on?  I've tried reinstalling the DK but that didn't help.  I'm suspicious about that driver installation failure but I don't know how to fix it.  Does anyone know how the DFU device should show up in the Device Manager?  I don't see anything new appearing there when the device is put into DFU mode.  

 

Could some driver conflict be happening?  I have other ST Micro device-drivers installed (i.e. ST/Link V2).

Outcomes