AnsweredAssumed Answered

STLink Utility Error

Question asked by Bob jenkins on Oct 15, 2017
Latest reply on Oct 15, 2017 by Clive One

I have a Nucleo STM32F446RE board, which I purchased less than a month ago.

After flashing it several times, I am now getting errors in flasher. I also checked my board with the STLink Utility.

When I press "Verify blank" I am getting a message "Can not read flash memory beyond address 0x08056000. Flash memory located below this address is blank."

Also, occasionally, when I press "Erase chip", the STLink Utility hangs and I have to restart it and the board.

 

I suppose this might be because the flash memory is worn out? But how can that be, if I have been using my Nucleo board for less than a month?

I have not  done any flash programming from within my code, and I barely made more than 50 program cycles on my board.

I tried updating the STLink firmware (using STLink Utility), tried connecting to the board holding the "Reset" button pressed, tried restarting the board multiple times (by disconnecting/connecting power)

Normally I am using this flasher utility: GitHub - texane/stlink: stm32 discovery line linux programmer 

Has anyone had similar problems?

Thanks for your responses!

Outcomes