AnsweredAssumed Answered

X-NUCLEO-CCA02M1 not recognized as sound device on PC

Question asked by Hisaharu Suzuki on Oct 12, 2017

Hi,

 

I am testing X-NUCLEO-CCA02M1+NUCLEO-F401RE by following below instruction (page 7-9).

http://www.st.com/content/ccc/resource/sales_and_marketing/presentation/product_presentation/d3/44/de/b9/33/a0/4e/25/x-n…

 

After that instruction, X-NUCLEO-CCA02M1+NUCLEO-F401RE should be recognized as

"STM32 AUDIO Streaming in FS Mode" in device manager of windows7 PC,

but not shown. Only virtual COM port is show in device manager.

 

I have tried below.

 

1. I followed another instruction on youtube, but I got the same result.

Getting started with MEMS Microphone expansion board (STM32 ODE) - YouTube

 

2. I build below firmware and debug it with system workbench

STM32CubeExpansion_MEMSMIC1_V2.0.1/Projects/Multi/Applications/Microphones_Streaming/SW4STM32/STM32F401RE-Nucleo/STM32F4xx-MEMSMIC1

 

But connect/disconnect callback functions are never fired when I connect/disconnect USB mini cable on X-NUCLEO-CCA02M1.

(I have set the breakpoints at HAL_PCD_ConnectCallback and HAL_PCD_DisconnectCallback in usbd_conf_f4.c)

 

Does anybody success to use as sound device on PC with the combination of X-NUCLEO-CCA02M1+NUCLEO-F401RE?

 

I also found similar question in this forum, but nobody answer...

X-NUCLEO-CCA02M1Evaluation program not recognized

 

I hope some hints or success information.

 

Thanks

 

#UPDATE 2017/10/16

 

I have switched to the combination X-NUCLEO-CCA02M1+NUCLEO-F476RG and it works perfecty.

I just followed to the above same instruction with re-soldering resiter at SBx pads.

(STM32CubeExpansion_MEMSMIC1_V2.0.1/Projects/Multi/Applications/Microphones_Streaming/SW4STM32/STM32F401RE-Nucleo/STM32F4xx-MEMSMIC1)

 

If you success with F401RE, please inform to this thread.

I don't want to throw away my F401RE...

 

Thanks

 

#UPDATE 2017/12/12

 

I have bought new NUCLEO-F401RE.

It works perfectly with X-NUCLEO-CCA02M1.

 

I compared the old NUCLEO-F401RE and new one, there is the difference of revision.

Old one is MB1136 C-01, the new one is MB1136 C-04.

 

I think some electric condition is difference.

But I could not found the documentation about revision of 401RE.

I give up!

 

Anyway, please check your revision if you encounter the same problem in future.

 

Thanks

 

 

cca02m1

mems microphones

f401re

Outcomes