AnsweredAssumed Answered

STM32L496 USART1 RX crash @ 1.8V IO

Question asked by john chen on Sep 12, 2017
Latest reply on Sep 13, 2017 by john chen

Dear community.

I have a very interesting issue - I am working on STM32L496 Nucleo board and working with USART1.  Everything works fine there with USART1 receive/transmitting in INT mode.  (Nucleo runs 3.3v with internal oscillator)

So, I then go make my own board, except that it runs in 1.8v instead of 3.3v.  I verified that my peripheral that I am talking to is also 1.8V IO, and I run the identical build on my own board.

For whatever reason, the STM32L496 crashes on USART1 receive.  I can send as much data as I want to, but whenever I tried to read anything back then system crashes (blinking LED GPIO is no longer blinking on my own board in another thread).

Also verified on the scope that the signals are indeed 1.8v, 9600 baud looks OK too.

BTW, I am running FreeRTOS, ARM GCC compile with Makefile.  I've read as much info as I can in setting up USART1 and things all look ok....  

Feeling is something going on with USART1 RX ISR?  not too sure.  but everything works great on the Nucleo.  I am out of ideas.

Anyone has anything for me to try?  *sigh*

Outcomes