AnsweredAssumed Answered

Freertos downport

Question asked by Luca R on Aug 28, 2017
Latest reply on Sep 4, 2017 by Imen D

Hi all,

I know that it is an uncommon request, but I need to use FreeRTOS 8.1.2, even if the latest version is 9.0.0.

 

I created the code base using STM32CubeMX, including FreeRTOS, and I got a complete project to start working on, linked to FreeRTOS version 9.0.0.

 

I have been asked by my company, for a number of reasons, to use version 8.1.2 instead.

I tried deleting the Middlewares folder and substituting it with the one with 8.1.2, but I get several errors when trying to compile my project (of course, those errors are not present if using the 9.0.0): console log is attached.

 

Any suggestion on how to proceed?

 

Thanks,

L

Attachments

Outcomes