AnsweredAssumed Answered

STemWin issues during linkage?

Question asked by Joachim SUSS Employee on Jul 27, 2017
Latest reply on Sep 8, 2017 by Imen D
Branched to a new discussion

Hi STM32 community

 

I'm tring to use STemWin in my project. I use IDE eclipse running on windows.I've created a project with STM32cubeMX V1.0 version 4.22 (STM32Cube_FW_F7_V1.7.0 firmware ).

After generating the project in C the compilation is OK.

When I test the example helloworld it's work. The library is OK. Perhaps something wrong in the initialisation?

I've added STemWin library and when I use GUI_Init() during the link I've the following error:

arm-none-eabi-gcc -mcpu=cortex-m7 -mthumb -mfloat-abi=hard -mfpu=fpv5-sp-d16 -L"C:\Users\joachim suss\Tableau_de_bord\Tableau_de_bord\STemWin_Lib" -specs=nosys.specs -specs=nano.specs -T"../STM32F746NGHx_FLASH.ld" -Wl,-Map=output.map -Wl,--gc-sections -o "Tableau_de_bord.elf" @"objects.list" -l:STemWin532_CM7_GCC.a -lm

C:\Users\joachim suss\Tableau_de_bord\Tableau_de_bord\STemWin_Lib/STemWin532_CM7_GCC.a(GUI_Core.o): In function `GUI__Config':

GUI_Core.c:(.text.GUI__Config+0xc): undefined reference to `GUI_X_Config'

GUI_Core.c:(.text.GUI__Config+0x10): undefined reference to `LCD_X_Config'

C:\Users\joachim suss\Tableau_de_bord\Tableau_de_bord\STemWin_Lib/STemWin532_CM7_GCC.a(GUI_Core.o): In function `GUI_Init':

GUI_Core.c:(.text.GUI_Init+0x34): undefined reference to `GUI_X_Init'

collect2.exe: error: ld returned 1 exit status

make: *** [Tableau_de_bord.elf] Error 1

 

Who have an idea about it?

Thank's for your help!

Joachim

Outcomes