AnsweredAssumed Answered

L6470: Several problems evaluating a Stepper-Motor Application

Question asked by b.s.keller on Nov 9, 2012
Latest reply on Nov 14, 2012 by Enrico Poli
Hello,
We are currently evaluating the L6470 to drive analytic high-pressure pumps for Mass spectrometry.

The final goal is to drive a stepper-motor in high precision micro-stepping mode at around 1.7 Nm at a maximum Speed of around 100 rpm.

For evaluation we used a small bipolar stepper-motor from a previous test with the following parameters:
       
  • Model: Trinamic QSH4218-51-10-049 (Short Specs attached)
  •    
  • Rated Phase Current: 1 A
  •    
  • Phase Current: 5 Ω
  •    
  • Phase Inductance: 8 mH
  •    
  • Measured K_e: 0.02041 (attached file: BMF Parameters)
As motor driver we used the EVAL6470H board attached to a STEVAL-PCC009V1 USB-SPI Interface in combination with the dSPIN Evaluation Tool 1.7.

Further Parameters:
       
  • Supply Voltage: 30 V

At our tests we tried to do some simple spin-up and down tasks on the motor with a blank axis and getting some experiences with the motor-driver.
But we faced several problems at this point:
       
  • The Motor accelerated at different rates (we tested 2000, 1000, 500, 100 Steps/s²) to different speeds.
        We tried to get it to as high as about 2000 Steps/s but it always stalled without any external force at about 1500 Steps/s (1/128 micro-stepping).
  •    
  • The "Command Error" Flag very often was set after setting parameters with the Evaluation Tool.
Here our Questions:
       
  • What could be the reasons the motor stalls at this stepprate and how could we avoid it in a "real world" application?
  •    
  • Why was the "Command Error" set? Is there any possibility of diagnosis? (Cables where really short, the one that was shipped with the STEVAL-PCC009V1, about 10 cm)
We really looking forward for your answers and thank you for your efforts in advance!

Sincerely yours

Outcomes