AnsweredAssumed Answered

issue with USB ULPI

Question asked by ml.michal on Jul 6, 2017

Hi,

 

please could anybody help me to find out what is wrong ?

i made 2 boards,first one is using STM32F779 and second one STM32F756,

from USB ULPI point of view they have same schematics and same PCB layout (connection to ULPI)

 

on board with STM32F779 i got running ULPI in device mode on first try, then i copied source code to STM32F756 and ULPI does not work :-(

i tried a lot of changes to get it work but i'm lost ...

i also implemented ethernet PHY onto both boards and ethernet is running correctly, i also tried to use USB in FullSpeed mode on HS core and it's running correctly, just ULPI on second board is not running ...

 

i'm getting errors on STM32F756:

[12616.508118] usb 1-4: new full-speed USB device number 18 using xhci_hcd
[12616.508226] usb 1-4: Device not responding to setup address.
[12616.716271] usb 1-4: Device not responding to setup address.
[12616.924154] usb 1-4: device not accepting address 18, error -71
[12617.044162] usb 1-4: new full-speed USB device number 19 using xhci_hcd
[12617.044308] usb 1-4: Device not responding to setup address.
[12617.252313] usb 1-4: Device not responding to setup address.
[12617.460164] usb 1-4: device not accepting address 19, error -71
[12617.580133] usb 1-4: new full-speed USB device number 20 using xhci_hcd
[12617.700183] usb 1-4: device descriptor read/64, error -71
[12617.928193] usb 1-4: device descriptor read/64, error -71
[12618.156175] usb 1-4: new full-speed USB device number 21 using xhci_hcd
[12618.276198] usb 1-4: device descriptor read/64, error -71
[12618.504197] usb 1-4: device descriptor read/64, error -71
[12618.612208] usb usb1-port4: unable to enumerate USB device

 

and when it works on STM32F779:

[13201.732380] usb 1-4: new high-speed USB device number 22 using xhci_hcd
[13201.753360] usb 1-4: New USB device found, idVendor=0483, idProduct=5740
[13201.753364] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[13201.753367] usb 1-4: Product: STM32 Virtual ComPort Bootloader
[13201.753369] usb 1-4: Manufacturer: STMicroelectronics
[13201.753372] usb 1-4: SerialNumber: 52765430981A
[13201.817553] cdc_acm 1-4:1.0: ttyACM0: USB ACM device
[13201.817969] usbcore: registered new interface driver cdc_acm
[13201.817971] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

 

please help me with some hints what to check or how to debug difference ...

i'm suspecting that ULPI fall into low power mode resp. suspend even when i everywhere disabled suspend or low power mode in HAL and my source code ...

 

 

Kind regards ...

Outcomes