AnsweredAssumed Answered

STM32F746ZGT6 problem with custom board [urgent]

Question asked by aksulu.mehmet_deniz on Jul 4, 2017
Latest reply on Jul 7, 2017 by Clive One

Dear all,

 

   We have been developing a custom board featuring STM32F746ZGT6, and we have encountered some problems.

   We are able to program the MCU using the ST-link with no problems, however, the MCU does not do anything! The PCB design was exactly based on the NUCLEO-STM32F746ZG board. We could not spot any differences between the NUCLEO board and our custom designed board (for the essential MCU components).  

   At first, we thought that it was a software problem so we tried the same software with the NUCLEO board and it worked fine. All the clock sources etc. are identical in both the NUCLEO and our custom board. Therefore we suspect that there is a problem with the hardware. It could perhaps be due to EMI?

   We have double checked all the connections and soldering.

   We are in a desperate situation. Do you have any ideas what could be the source of such a problem? 

 

All help would be appreciated. Please let me know if you need any more information.

 

All the best,

Mehmet Deniz Aksulu

Outcomes