AnsweredAssumed Answered

UART problem on L452RE

Question asked by Jonas Chr on Jun 30, 2017
Latest reply on Jul 1, 2017 by Clive One

Hello guys,

 

I am still working on a LoRa node on the basis of a Nucleo board. It seems as nobody knows how the LoRa middelware can be ported, to use for example a SX1272 shield Add LoRa middleware/driver to different boards to use CubeMX . Now I go with the LoRa Soc called Microchip RN2483, which is a very easy to use with ASCII commands via the UART interface. When I try to send ASCII messages to the SoC there ist mostly bit 5 varying and some others are lost. That means, when I just send the same message and look on the stream, every message is different. I have looked on the bits with an oscilloscope, so this might be verified ;-)

 

It seems like there is a problem with the MSI clock, so UART has too much jitter. Does anyone have the same problem and solved it, or any suggestions, what might be wrong?

 

What I tried and does not help:

1. Used different L452RE boards.

2. I wrote working code on the L152RE board, where messages are send correctly. Put just the sending code on the L4.

3. Put an extern 8 MHz oscillator with two 22 pF on it and configured clock with CubeMX. Maybe I have to spend some more days, to vary setting on that.

 

Thanks in advance

Jonas

Outcomes