AnsweredAssumed Answered

Read Out Protection enabled without any action

Question asked by Viony V on Jun 30, 2017
Latest reply on Jul 4, 2017 by Viony V

Hi everyone.

 

I was working on a custom STM32F469NIH board for the past two weeks. This morning when I tried to supply for the first time during this day the board to start its program, it didn't. When I connected it to a ST-Link debugger (built-in in the DISCOVERY board) through SWD, the ST-Link Utility displayed "Can not read memory ! Disable Read Out Prorection and retry !". Till then, I programed the MCU through SWD.

 

I did not set the RDP bytes. Yesterday when I left the office, everything was working fine, perfectly fine. Today, everything don't. It is the second time it happens...

The first time was with the same custom board (two manufactured). It worked for more than two weeks too (with multiple flash program procedure during each day with no issues). The same way, a  morning nothing worked with the same displayed warning. For the first time it happened I thought I did something wrong with the software but today, I know I didn't. Two boards bricked in one month with no apparent reasons.

 

Changing the Option Bytes option in STM32 ST-Link Utility doesn't work. I have an error when it try to change them. Same with the Full Erase operation.

 

My custom board is highly common with the STM32F469-DISCO board schematic. I tried to connect it through USB and setting BOOT0 high and BOOT1 low but the board doesn't seem to be detected (working on Windows 7 x64) and nothing appears in DFU software.

 

Do you have a solution ?

 

I saw that someone also had this kind of issue with a STM32F37 but I don't know if he managed to solve the issue. What I don't understand is, even if it is indeed the RDP bytes that have been set (by somehow dark magic), why my program didn't start ? I mean, the RDP bytes are supposed to protect the flash program, not prevent him to start.

 

Thank you in advance.

Outcomes