AnsweredAssumed Answered

STM32F401CC bootloader problem

Question asked by hexfet13 e on Jun 28, 2017
Latest reply on Jun 28, 2017 by Clive One

Hi all,

i have two custom board with a microcontroller STM32F401CC in a 48pin package. One of these two micro is not working anymore due to a programmed option byte during a debug session. ST-link tell me this micro has a "read out protection" set to level 1 instead level 0.

I tried to restore the level 0 with ST-link utility, but it can't restore the original stete to level 0(STlink gives me the correct id and microcontroller number)

 

So, i'm trying to restore this microcontroller with the utility Flash Loader Demonstrator, using the UART1 ( pins: boot0=HIGH, boot1=LOW) using an  usb-serial adapter with this parameter 9600-8-EVEN btu i receive always the same reply:

Unrecognized device... Please, reset your device then try again.

 

I tried to use the serial bootloader with the second board (this is 100% working) and i have always the same reply:

does anyone can tell me how to solve this problem?
Thanks!

Outcomes