AnsweredAssumed Answered

Hightec compiler problem with SPC5Studio

Question asked by stefano maccari on Jun 27, 2017
Latest reply on Jun 28, 2017 by Erwan Y

Hello everyone,

 

I have a problem with the Hightech compiler used in SPC5Studio, I try to explain my issue: on my PC I have installed the SPC5Studio v5.0.0 and the Hightec compiler toolchain v4.6.6.1.

I configured the SPC5 Studio to use the Hightech compiler by adding the following values in the PATH:

 

C:\HighTec\toolchains\powerpc\v4.6.6.1\bin;

C:\HighTec/licensem

 

situated under

 

Windows -> Preferences ->C/C++ -> Build -> Environment  (see the attachment )

 

 

I made a test project, builded it and all worked fine, but if I close the SPC5 Studio then reopen it and build again the project (after a clean) the buildin doesn't work anymore; I checked under

Windows -> Preferences ->C/C++ -> Build -> Environment and the values:

 

C:\HighTec\toolchains\powerpc\v4.6.6.1\bin;

C:\HighTec/licensemanager

were missing in the PATH, the only way to make it work is to copy again in the PATH these two values.

 

Then I tried to add a new variable and copy in it the two values, but it didn't work too.

 

I'm asking if there is a way to avoid the copy of the values every time I close and open the SPC5 Studio.

 

Thank you in advance.

Stefano Maccari

Outcomes