AnsweredAssumed Answered

NUCLEO-L073 USB troubles.

Question asked by Simon Lund on Jun 8, 2017

I am having troubles with making a USB CDC device of a Nucleo-L073.

 

I have downloaded the STM32Cube_FW_L0_V1.9.0 projects and have tried building and running the \STM32L073Z_EVAL\Applications\USB_Device\HID_Standalone\MDK-ARM project in Keil.

I disconnect the USB cable from the ST-link and move jumper JP5 to PWR E5V, and connect my USB cable to E5V and GND on pin row and connect +/-data to A11/12 (have also tried A12/11). Every time I connect to the PC I get an USB error message "Unknown device" code 29.

X2 is mounted on my Nucleo, is that sufficient for USB? Or do i need the X3 instead?

 

Have someone successfully made a CDC or HID device from a Nucleo-L073? or with a STM32L072?

 

  /* Init Device Library */
  USBD_Init(&USBD_Device, &VCP_Desc, 0);
  /* Add Supported Class */
  USBD_RegisterClass(&USBD_Device, USBD_CDC_CLASS);
  /* Add CDC Interface Class */
  USBD_CDC_RegisterInterface(&USBD_Device, &USBD_CDC_fops);
  /* Start Device Process */
  USBD_Start(&USBD_Device);

Attachments

Outcomes