AnsweredAssumed Answered

FatFS version too old in CubeF4 library

Question asked by Dulan D on May 30, 2017

Hello,

 

By using the STM32Cube_FW_F4_V1.16.0, there is the FatFs which is provided by default as third party software. I see that the version of that FatFs is very old: R0.11. There are 6 new fixes that occurred since then and it improved things a lot. Also there is the exFat which is now supported.

Changelog:

http://elm-chan.org/fsw/ff/updates.txt

Website:

http://elm-chan.org/fsw/ff/00index_e.html

 

Would it be possible to update the latest release into CubeF4 middleware? I think that this should also be done with all other middleware, so people have directly the best products available freely.

 

Thank you.

Outcomes