AnsweredAssumed Answered

Very minor STM32Cube MX bug: DMA2 FIFO Mode checkbox can't be unchecked

Question asked by Ivanishvili.Giorgi on May 24, 2017
Latest reply on Aug 18, 2017 by Angus Cunningham-Burley

Hello, everyone!   

Few days ago accidentally found that DMA FIFO mode checkbox can't be unckecked.

However it should not be a problem to simply change "DMA_FIFOMODE_ENABLE" to "DMA_FIFOMODE_DISABLE" in code. I think this could be a minor bug.

I'm using latest CubeMX version 4.21.0

 

Screenshot here:

Outcomes