AnsweredAssumed Answered

Getting jump-started with STM32F429ZIT6U

Question asked by lynch.gary on Sep 10, 2014
Latest reply on Sep 11, 2014 by Andrew Neil

My boss recently gave me a 32F429IDISCOVERY board and asked
me to familiarize myself with the hardware, install and
learn a development environment, and teach myself how to
develop apps for the board, and run one on this hardware.
There are follow-up tasks after that, but I will limit
this plea to just implementing a "Hello, world!" program 
on the Discovery board.

Although I have been developing embedded controls for over
30 years, this is my first outing with an ARM product.

My boss also gave me a list of links to resources at ST
Micro, from which I learned there are a least 4, 3rd-party
IDEs to support this processor. I chose to focus on the Keil
MDK-ARM™ because it is based on uVision4, which I have
already used with other processors and thus can bypass a
significant chunk of the learning curve.  According to the
documentation I can run it for free as long as I keep my
app size under 32k (and I hope you can do something useful
with that).

I contacted our local Arrow outside sales rep and he gave
me a massive data dump which includes notes from a jump-
start seminar they gave in March.  There is a class on the
STM32F4x family of processors (450 slides), another on the
STM32F3x Standard Firmware Library, and a 3rd (Called "hands
on" which seems to be a lab on getting your first STM32F4x
application to run.

I have data sheets and users manuals on more processors and
eval boards than I can shake a stick at, and wading my way
through the pile will be a task in itself.

Based on the info I had, I downloaded a file from Keil
called mdk511a.exe and had to go through my IT department
to get it installed.  The installation seemed to terminate
normally, but when I tried to re-start it the next day I
discovered the install had left no shortcut in either my
Start bar or my Desktop. Looking in my (new)
C:\Keil_v5\ARM\BIN folder I found exactly two
executeables:
- ElfDwT.exe
- FCARM.exe

which I attempted to launch with the "Run..." command. But
nothing happened.  So I am clearly not informed enough to
complete even this very fundamental step.

I tried to go back to my Arrow rep, but he is on vacation
(I am in Europe, and they take vacation very seriously
here.)

Does anyone have any pointers to get my first app up and
running (including getting beyond what is probably a stupid
mistake)?

Thanks.

Outcomes