AnsweredAssumed Answered

Issue with STM32F401RE and X-Nucleo-53L0A1(not working)

Question asked by Armin Böss on Apr 9, 2017
Latest reply on Apr 14, 2017 by Armin Böss

I tried to program the STM32 MCU with the example code (RangingWithSatellites) from here : X-NUCLEO-53L0A1 - Ranging sensor expansion board based on VL53L0X for STM32 Nucleo - STMicroelectronics (X-CUBE-53L0A1, bottom of the page).

 

At first, i just tried to drag and drop the .bin file (from this directory: \X-CUBE-53L0A1\STM32CubeExpansion_VL53L0X_V1.2.0\Projects\Multi\Examples\VL53L0X\RangingWithSatellites\Binary) on to the F401RE Board, which worked sometimes, but not every time. I can´t figure out why it behaves like this, i tried to unplug the sensor shield, program the board and reattach the sensor shield and stuff like this but after hours, it just feels like someone is rolling some dices about whether it will work or not (what i mean with not working: the LED on the F401RE stays red and the display on the sensor shield stays dark/doesn´t react to the reset button).

Second, i programmed the MCU with the STM32 ST-LINK Utility. After programming, the Console says everything is fine and the Code is in the FLASH but this never worked for me.

Finally, i tried it with the System Workbench for STM32, but the results didn´t change.

 

Can this be a hardware error or am i doing something horribly wrong?

 

Best Regards and an apologize for my english,

Armin

Outcomes