AnsweredAssumed Answered

STEVAL-IHM042V1 connection failed

Question asked by Misak.Daniel on Apr 3, 2017
Latest reply on Dec 5, 2017 by Electric Forest

Hello,
                I am using STEVAL-IHM042V1 and Motor Control Workbench. Everything was working fine until I tried to connect the board via the Motor Profiler.  STEVAL-IHM042V1 is not available for Motor Profiler so I chose other board with same L6230 driver. Since that, I cannot connect my STEVAL-IHM042V1 in Motor Control Workbench – I get an error „Connection failed...

According to the error message I tried following:

checked the power supply,

checked and tried all possible baudrates, COM address and other settings in Windows device manager,

tried various cables,

updated ST-Link driver via ST-Link Utility,

installed (updated) STM32 Virtual COM port on my computer,

tried all these things on other computer.

None of these worked. The User manual says that the board is mounted with STM32F103C8 preprogrammed with STM32 Virtual COM Port firmware providing USB-serial interface. Is it possible that the firmware was erased somehow? Eventually, can I reprogram it?

 

Thanks, 
Dan.

Outcomes