AnsweredAssumed Answered

BlueNRG-MS Central Peripheral Pairing Problem

Question asked by Muhammad Waseem Abbas on Mar 31, 2017
Latest reply on Apr 3, 2017 by Andrea Palmieri

Hi All,

 

I am running BLE central and peripheral profile applications on Mentor Graphics Nucleus RTOS using two STM32 MCUs interfaced with BlueNRG-MS modules. BlueNRG-MS firmware version is 7.2a, STSW-BLUENRG-DK version is 2.01 and profile libraries have been used from OSXSmartConnPS package (V1.5.0). 

 

The problem is that when I try to connect master and slave using any method for Temporary Key Calculation, the pairing fails and packets are not encrypted when seen from Wireshark logs while the same applications pair successfully when run in bare metal environment using NUCLEO-L476RG and X-NUCLEO-IDB04A1 BlueNRG expansion board. The Wireshark logs for both the cases are attached. Any help in this regard will be highly appreciated.

 

Security parameters on central and peripheral sides used for pairing are as following:

:::PERIPHERAL SECURITY SETTINGS:::

ioCapability = NO_INPUT_NO_OUTPUT;
mitm_mode = MITM_PROTECTION_REQUIRED;
bonding_mode = BONDING;
OOB_Data_Present = OOB_AUTH_DATA_ABSENT;
Use_Fixed_Pin = USE_FIXED_PIN_FOR_PAIRING;
encryptionKeySizeMin = 8;
encryptionKeySizeMax = 16;
Fixed_Pin = 111111;
initiateSecurity = SLAVE_INITIATE_SECURITY;

 

:::CENTRAL SECURITY SETTINGS:::

IO_CAPABILITY = KEYBOARD_DISPLAY
MITM_MODE = MITM_PROTECTION_REQUIRED
OOB_ENABLE = OOB_AUTH_DATA_ABSENT
USE_FIXED_PIN = USE_FIXED_PIN_FOR_PAIRING
FIXED_PIN = 111111
BONDING_MODE = BONDING

Outcomes