AnsweredAssumed Answered

FOC SDK Wont Run Beyond Start-Up Sequence

Question asked by Tom Paynter on Mar 30, 2017
Latest reply on Apr 7, 2017 by Enrico Poli

Hi All,

 

Im Tom, Im net to the ST Community! 

 

I have the X-Nucleo IHM07M1 and the Nucleo F302R8 dev boards trying to run the STM FOC SDK 4.3 library. I have the Bull Running motor which came with the kit which I have managed to set-up and is running well, I also have another hobby sized motor all set up and running as I would like.

 

However I also have a smaller 2 pole, (R = 14 Ohm, L = 4.6 mH) which I would like to run also through the sensorless FOC. However, once I put in the new parameters it spools up, as per the startup sequence, but does not swap over to the FOC control. Giving Speed Feedback errors. I have tried everything as mentioned in the FAQ to remedy this (page 16) yet it still doesnt run properly. 

As suggested on page 16 I reduce the G2 parameter, but once it gets beyond a certain point (about 800) it then speeds up to the full ramp up speed and gives a Start up error. 

 

Also as suggested on page 16, I have the startup verification speed at about 40% to 90% application speed and it still unable to start up properly.

 

I have tried as much as possible and still I have no idea how to make it work.

 

Thanks in advance,

 

Tom 

Outcomes