AnsweredAssumed Answered

I think the STM32F7 Ethernet MAC does not work well in RMII mode.

Question asked by mendes.ari.001 on Mar 22, 2017
Latest reply on Oct 11, 2017 by Joerg Wagner

Using the STM32CubeMx v4.20, I did a webserver with a custom page that show two pictures of about 27KB each. I tested the webserver with the STM32F746G-DISCO , NUCLEO-F746ZG and  NUCLEO-F767ZI.

What happens is that when I press F5 to reload the page in the web-browser, most times it takes a long time to reload the pictures. See Wireshark captures in anexo.

 

When I tested the same page with the same LwIP configuration in the FRDM-K64F board (RMII using KSZ8081RNA), it works ok, I can press F5 very fast and the page always reloads very fast. I also teste in a STM32F407-EVAL board (MII mode) and also worked fine.

 

  I  put an external SPI ethernet controller in the NUCLEO-F746ZG and I only changed the ethernetif.c to redirect the packets to the external controller. And the webserver also worked fine, always with fast reloads.  

   

  So the problem should be the hardware MAC/PHY of the STM32F7 boards or the CubeMx Ethernet driver.

   

  Did someone also experience this problem on some STM32F7 RMII boards?

Outcomes