AnsweredAssumed Answered

Fixing J-Link "No emulators connected via USB": How to have J-Link work for both Segger Utilities and VisualGDB (although probably not concurrently)

Question asked by Immpypi.Goj on Mar 19, 2017

I recently discovered that after using VisualGDB to connect to my STM32 - that none of the Segger utilities worked any more.  Just a message: "No emulators connected via USB" (despite other software seeing the J-Link)

 

Upon testing OpenOCD in Visual Studio w/VisualGDB, this message will pop up, wanting to change the USB drivers:

:VisualGDB Prompt for USB change

 

Once changed, none of the Segger J-Link utilities will work any more (not a surprise). Making it work again? Not so easy.

 

I've posted some information on my experience and detailed instructions on how I fixed it:

 

http://gojimmypi.blogspot.com/2017/03/Segger-J-Link-STM32-with-VisualGDB.html

 

In short: delete Segger USB and software from control panel, re-install fresh, then manually update USB drivers with the code in your install directory, in my case:

 

C:\PROGRAM FILES (X86)\SEGGER\JLINK_V614B\USBDRIVER\

 

I am cross posting this to both the st.com and sysprogs.com forums in the hopes that both companies will contact each other and come up with a more graceful solution to switching between tools.

Outcomes