AnsweredAssumed Answered

Problems to transmit Data with USB CDC and FreeRTOS

Question asked by Christoph Eschenbach on Jan 26, 2017

Hello there,

I am trying to set up a VCP with USB CDC Device on a Nucleo144 with STM32F429ZI+FreeRTOS simulate UART connection with Host PC.

With CubeMX i could start fast to a simple Transmit to Host PC via CDC_Transmit_FS()-function(without FreeRTOS).

Then Problems started. I couldnt reconnect with Terminal and redo the project. So I started search and found several fixes, like change heap and stack size, vbus disable,change APP_DATA_TX/RX_SIZE. Everything worked again without problems.

Then I stepped back to CubeMX and enabled FreeRTOS and did the same change heap and stack size ...

The Problem: I can connect with the Terminal but not when i try to send with CDC_Transmit_FS()

I gave enought Time for the USB_Device_Init() to finish but the moment I try to transmit, I can no longer connect via Terminal.

So far I have seen the CDC_Standalone from the EVAL-board application and will try to "translate" it to my device.

But first thing I experienced as I enabled a USART and a Timer for my working Project in CubeMX was that i couldnt even connect via Terminal which worked before.(All necessary changes were made as before)

Disabled both again->generated Code->Could connnect again.

Feels like random things happening generating code with CubeMX. Its really frustrating to get hung up on such problems for days.

I know at the end problems come most time from less knowledge. but where to start searching when things like this happen?

 

The shorter Question. How can i come from CubeMX generated code with FreeRTOS to Transmit Data to a Terminal?

Did I miss Important settings for this in CubeMX as I enabled USART and another Timer?

Outcomes