AnsweredAssumed Answered

STM32CubeMX STM32F4 Library Install Problem

Question asked by Petras.Jason on Jan 24, 2017
Latest reply on Dec 26, 2017 by John Griswold

Hello all, 

 

I am running into a problem with updating the STM32F4 library in STM32CubeMX ver 4.19. I want to install the STM32F4 library package ver 4.14. However, I get an error stating "These Files have problem during Download : stm32cube_fw_f4_v1140.zip (Target directory already exists)" 

 

I am able to install the previous STM32F4 package, rev 1.13 without problems. 

 

I have tried uninstalling, reinstalling, deleting the repository package directory, etc, etc. No dice. Perhaps I am missing a directory to clean up while reinstalling. Also, I can see where the .zip is downloaded to when running the updater. There is nothing there. It shouldn't have any problems. I also tried installing the package via the "Load from file", but no dice there. I get an error that way too. 

 

I also thought that the package may have already come with CubeMX, but I am prompted to download the package when I try to generate code.Of course, this fails for the same reason

 

So, long story short, I am stuck. I would appreciate the help! Looks like there are others who have had issues in the past, but there are no answers.I listed on below. 

 

STM32CubeMX, cannot install FW package for STM32F4 

Outcomes