AnsweredAssumed Answered

lps22hb no pressure and temperature response

Question asked by Kondo.Masahiro.001 on Dec 11, 2016
Latest reply on Dec 12, 2016 by Kondo.Masahiro.001

I have connected LPS22HB development kit (STEVAL-MET001V1) and Raspberry Pi 3 with I2C interface and tried to read pressure and temperature data but whatever setting I tried, pressure (0x28, 0x29, 0x2A) and temperature (0x2B, 0x2C) always gives me 0xff. I tried one shot (CTRL-REG1 0x00, CTRL-REG2 0x11) and also continuous (CTRL-REG1 0x12, CTRL-REG2 0x10) but these didn't make any difference, and I can read WHO AM I register and all other registers but pressure and temperature output always 0xff, 0xff, 0xff,0xff, 0xff (with single byte read or dump). I am sure I did something wrong but can't figure this out. Has anyone experienced something like this? Register 0x27 shows 0x03 but I still can't read data out (0xff).. Please see the attached screenshot for dump data.

 

I hope someone could help me to make this chip work..

 

Regards.

 

Attachments

Outcomes