AnsweredAssumed Answered

STM32F4-Discovery EEPROM emulation demo does not work

Question asked by Kim.Hansuk on Dec 7, 2016
Latest reply on Dec 13, 2016 by g.c.003

I have STM32F4-Discovery board. (MB997B with Discovery-MO expansion board)

From STM32Cube package, I ran several examples, applications and demo successfully. But EEPROM_Emulation application does not work well.

STM32Cube_FW_F4_V1.13.0\Projects\STM32F4-Discovery\Applications\EEPROM\EEPROM_Emulation

When I start program, LD4 is blinking, indicating error is occurred. I tracked step-by-step, so error occurred here.

--

EE_Init(void)
switch (PageStatus0)
/* Page0 valid, Page1 receive */
              /* Transfer the variable to the Page1 */
              EepromStatus = EE_VerifyPageFullWriteVariable(VirtAddVarTab[VarIdx], DataVar);
              /* If program operation was failed, a Flash error code is returned */
              if (EepromStatus != HAL_OK)
              {
                return EepromStatus;
              }

 

main()

  /* EEPROM Init */
  if( EE_Init() != EE_OK)
  {
    Error_Handler();
  }

--

I tried this with EWARM 7.70 and SW4STM32 and the result are same.

I don't understand why it does not work. I changed nothing in the program. There seems no hardware configuration.

Outcomes