AnsweredAssumed Answered

Connection to UART for a beginner

Question asked by Antoine Wajntraub on Aug 10, 2016
Latest reply on Aug 23, 2016 by Gerardo Gallucci
Hello everyone ! 

I'm sorry about those dumb questions, but I just began my internship 2 days ago in a company that wants to work with the SPWF01SA module. They gave 2 boxes and no explanation. And the guy who used to work on it left. So I'm alone with that...

In one of those boxes, there is a Silica Branca board, an eval board for the module. I followed the guide here but something doesn't work, and I don't know why. My computer recognizes the card as a COM device, and I can connect it thanks to Tera Term. But that's it. Once it's connected, I don't have any message, and when I try to send the "AT" command, it doesn't respond. It doesn't respond at any command. I tried with Putty and Termite, same problem. But with Termite, sometime, I have a bunch of "[00]"'s that look like it's sent by the card. Sometimes I have 2 or 3, sometimes I can have hundreds of them. And that's everything I can get from that card.

In the other box, I have another board, a home-made one. The company has its own board, and integrates the Wifi module on it. The engineer who left soldered some wires directly on the wifi module. There are on GND, RXD1, TXD1 and BOOT0. In the same box, I have 2 cables (TTL-232R-3V3, page 11). So, I guess, he wanted to connect directly the module to his computer through that TTL/USB cable, right ? Could I have an UART connection like that ? If yes, should I solder some wires to CTS1 and RTS1 ?

Thanks for your answers, and sorry for the beginner questions, but my coworkers can't answer me, and I'm on my own now...

Regards,

Antoine

Outcomes