AnsweredAssumed Answered

lypus atm8s discovery flasher tool released for linux amd_64

Question asked by tuxd3v on Mar 27, 2015
Latest reply on Nov 14, 2015 by tuxd3v
Hi guys...

Lypus 0.5.0 is released :)

The backend of lypus is already multiprotocol! :)

It work using stm8s discovery board, via Bootloader, or Reply mode protocol...STlink is now been worked out... ;)

So you need to use a usb/serial cable to connect.

What it support:

bootloader 0x13.

read,
write,
erase,
go(start running code at specified zone or address)

the parser ONLY WORK IN BINARY MODE FOR NOW!!
SO Don't write s19 or ihx format files directly to mcu, as it could provoce damage on mcu, since mcu WILL interpret the hexa format as opcodes, or address, and maybe will burn your MCU, which I can't be responsible for your actions!

to convert from ihx or s19 to bin you can use hex2bin project, look on github(in the future will be supported a parser that will do this in lypus :) ).


verify is not yet supported not because its difficult, but because the focus now is stlinkv1 protocol :)

jump on :
https://meocloud.pt/link/d1a42ac2-a022-4661-aee2-a1a2188c4c6a/LyPus/

and get version for linux amd_64.

If lypus desktop home directory doesn't exist, or if /tmp/lypus doesn't exist, it creates them ;)

remember to enter bootloader mode you need to reset mcu, and you have less than one second to press the initialization stuff...

jump on build folder and run, imediatly after reset "./lypus --mcu stm8s105c6 --proto uart --baud 115200 --dev /dev/ttyUSB0 --session --info"

this command above at least for me works nice if I run it after ~0.3-0.5 seconds after reset...

after you successful enter in bootloader mode you will get info command with
./lypus --session --info

some examples :
./lypus --session --read --zone flash(reads all flash zone)
./lypus --session --write --zone flash --file default_app.bin(writes to flash the program default_app.bin, in this case)
./lypus --session --erase --zone flash(erase all flash to 0x00)
./lypus --session --write --addr 0x8080 --value 0xff(write 0xff value to addr 0x8080)
./lypus --session --read --addr 0x8080 --number 1(reads the content of flash addr 0x8080)

type ./lypus --session --help to see options :)

Lypus can support another mcu's that have bootloader 0x13..if you have created a json file for them on maps folder..

what you think about this program?
give me some feedback.
hope this program can be useful to you.

regards
tux

Outcomes